<!DOCTYPE html>
<html lang="en-US">
<head>
	<meta charset="UTF-8" />
	<link rel="pingback" href="https://minnesota.cbslocal.com/xmlrpc.php" />

<!-- WP Header - Start -->
<meta name="news_keywords" content="jared gaustad, martha gaustad, kari gaustad, river falls wisconsin, wisconsin, western wisconsin, river falls home explosion, wisconsin home explodes" />
<meta name="keywords" content="jared gaustad, martha gaustad, kari gaustad, river falls wisconsin, wisconsin, western wisconsin, river falls home explosion, wisconsin home explodes" />
<meta property="fb:pages" content="85063973824" />
<meta name="google-site-verification" content="44caXBf4kjHeKKAT7ZZ89NaCX25utL_yRSa-qGpwIhY" />
<title>Man Mourns Grandmother Killed In River Falls Home Explosion &#8211; WCCO | CBS Minnesota</title>
<link rel="dns-prefetch" href="//cdn.cookielaw.org" />
<script type="text/javascript" charset="UTF-8" src="https://cdn.cookielaw.org/scripttemplates/otSDKStub.js" data-domain-script="7547764e-53b9-4fff-aef7-ce9cb429c721"></script>
<link rel="dns-prefetch" href="//production-cmp.isgprivacy.cbsi.com" />
<script type="text/javascript" charset="UTF-8" src="https://production-cmp.isgprivacy.cbsi.com/dist/optanon-v1.1.0.js"></script>
<script type="text/javascript">!function(n){var o=window,a="cbsoptanon",c="cmd",d="config";o[a]=o[a]?o[a]:{},o[a][c]=o[a][c]?o[a][c]:[],o[a][d]=o[a][d]?o[a][d]:[],["onScriptsReady","onAdsReady"].forEach(function(n){o[a][n]=o[a][n]||function(){var d=arguments;o[a][c].push(function(){o[a][n].apply(o[a],d)})}})}();</script>
<link rel='dns-prefetch' href='//w3.cdn.anvato.net' />
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//wayne.cbslocal.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel='dns-prefetch' href='//jetpack.wordpress.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//public-api.wordpress.com' />
<link rel='dns-prefetch' href='//0.gravatar.com' />
<link rel='dns-prefetch' href='//1.gravatar.com' />
<link rel='dns-prefetch' href='//2.gravatar.com' />
<link rel="alternate" type="application/rss+xml" title="WCCO | CBS Minnesota &raquo; Feed" href="https://minnesota.cbslocal.com/feed/" />
<link rel='stylesheet' id='all-css-0' href='https://minnesota.cbslocal.com/_static/??-eJytj0sOwjAMRC9EsLIolAXiLGliSlTHjvJRr09I2bCCSqxsj/1GY1ijssIFuUB5YMAMdsqKxBoCz5aqe0k5w12kYDq29gA/QRgmdBsbE5IY9x2OVGfPGYK4Sm1j3gat7of7gQqGzYyp23woqoVcisQdL20eNUxsPCnyvPw/FVKbuPR/b+Gqh8tpOI9aj0910J9k' type='text/css' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='cbs-font-awesome-css'  href='https://maxcdn.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.min.css?ver=4.7.0' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='cbs-lato-font-css'  href='https://fonts.googleapis.com/css?family=Lato%3A300%2C400%2C700%2C900&#038;ver=1.0.0' media='all' />
<link rel='stylesheet' id='all-css-4' href='https://minnesota.cbslocal.com/_static/??-eJyNy8EJgDAMQNGFrKEHtR7EWWoMKqRpIRFxe+0C4vXzPlzFYRYjMbCdEingoo4zRga1m6lF1Qa+2CHI51qTKpS4kTNKhaP9eOtC/EYxrXpOk+/GvhuC9+EBIg45Jw==' type='text/css' media='all' />
<link rel='stylesheet' id='cbs-custom-css-css'  href='https://wayne.cbslocal.com/cbs-local-custom-css/global/cbslocal_custom_global.css?ver=1.0.0' media='all' />
<link rel='stylesheet' id='all-css-6' href='https://minnesota.cbslocal.com/_static/??-eJydkt1uwyAMhV9olKbqJu1i2rM44KYsgBE4Tfv2M01/1HXa2lxEOjicz8eAHpMyFBkja95iwKJNW5QnA14nP3QuFh3IDl7+HDeoABE6zNoUqRwSrheiXvRfIBeNH2wtiWd0FhVjSB4Yy5PmBJkf8PxMXraU2dCZcl0+0R5Di3byH6XyrrAywOCpe3IMmcIZj2p3f3jn6PIxdBmC2iDaKXarrtWVWi2Cixf/Dd9KNN1K415SthnyQRc+eLxxPHx6cmMd8uX2qr6DhEGdbV/ICaTz+2J9h9iAwZaoxupF7E+xZtKYkkpURP2OmfGiA+S+oqf9hjzlGe/tPy7tMI/Z8cOTV8RpXS2f4aN5a9bLZvm6Wn4DzXhoqg==' type='text/css' media='all' />
<style id='wp-block-library-inline-css'>
.has-text-align-justify{text-align:justify;}
</style>
<script type='text/javascript' src='https://minnesota.cbslocal.com/_static/??-eJy1UEEOwjAM+xAlGwI0Doi3lK4bLWlalhS031MmDuw2kDhZcWzHCjySMpHEkoBcbLAM5swKo9EIjgzmtlCeIUUcO4e4Do7Wnlew1OgXORLm3hFDiG3GstHtZC6g7pvPhFn0LdthfMMikQquH7TYnzpNAhU06d4Or+gZocq9q8T01XO6TEZcJP5HIYtlIuGSewrHel9vq+rQ7Br/BLDAujw='></script>
<script src='https://w3.cdn.anvato.net/player/prod/v3/scripts/anvload.js?ver=5.6.2' id='partner__video__anvato-js'></script>
<script type='text/javascript' src='https://minnesota.cbslocal.com/_static/??-eJyFjcEOwjAMQ3+ILephMA6Ib+naqEuVphNJ2e+vQly4sJtlP9uwb0OoYigGtmJBhbDowDV4BpLALXYrK/i4otIbx0IyZr3Av2LnE9fF8yn5c/EyCoynnY1bIlEoNTbuyU4xoX0mvrJPPMvDTffrdJudm/MBCxBU3Q=='></script>
<link rel="https://api.w.org/" href="https://minnesota.cbslocal.com/wp-json/" /><link rel="alternate" type="application/json" href="https://minnesota.cbslocal.com/wp-json/wp/v2/posts/1002373" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://minnesota.cbslocal.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://minnesota.cbslocal.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.6.2" />
<link rel='shortlink' href='https://cbsloc.al/3uMSVqj' />
<link rel="alternate" type="application/json+oembed" href="https://minnesota.cbslocal.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fminnesota.cbslocal.com%2F2021%2F03%2F01%2Fthe-worst-night-of-my-life-man-mourns-grandmother-killed-in-home-explosion-mother-recovering-from-burns%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://minnesota.cbslocal.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fminnesota.cbslocal.com%2F2021%2F03%2F01%2Fthe-worst-night-of-my-life-man-mourns-grandmother-killed-in-home-explosion-mother-recovering-from-burns%2F&#038;format=xml" />
<style type='text/css'>img#wpstats{display:none}</style>
<meta property="og:title" content="Man Mourns Grandmother Killed In River Falls Home Explosion" /><meta property="og:image" content="https://minnesota.cbslocal.com/wp-content/uploads/sites/15909630/2021/03/River-Falls-Home-Explosion.jpg?w=1500" /><meta property="og:image:secure_url" content="https://minnesota.cbslocal.com/wp-content/uploads/sites/15909630/2021/03/River-Falls-Home-Explosion.jpg?w=1500" /><meta property="og:image:width" content="1500" /><meta property="og:image:height" content="844" /><meta property="og:description" content="A mother and son are working together to heal, one month after a deadly explosion in western Wisconsin." /><meta property="og:type" content="article" /><meta property="og:url" content="https://minnesota.cbslocal.com/2021/03/01/the-worst-night-of-my-life-man-mourns-grandmother-killed-in-home-explosion-mother-recovering-from-burns/" /><meta property="article:published_time" content="2021-03-01T22:12:37+00:00" /><meta property="article:suggested-social-copy" content="A mother and son are working together to heal, one month after a deadly explosion in western Wisconsin. " /><meta property="article:opinion" content="false" /><meta property="article:content_tier" content="free" /><meta property="og:category" content="Links &amp; Numbers,Local,News,Seen On WCCO-TV,Syndicated Local,Watch + Listen" /><meta property="article:publisher" content="http://facebook.com/CBSMinnesota" /><meta property="article:author" content="http://facebook.com/CBSMinnesota" />

<meta name="twitter:card" content="summary_large_image"/><meta name="twitter:image" content="https://minnesota.cbslocal.com/wp-content/uploads/sites/15909630/2021/03/River-Falls-Home-Explosion.jpg?w=1500"><meta name="twitter:title" content="Man Mourns Grandmother Killed In River Falls Home Explosion"/><meta name="twitter:description" content="A mother and son are working together to heal, one month after a deadly explosion in western Wisconsin."/><meta name="twitter:site" content="/wcco"/>
<link rel="canonical" href="https://minnesota.cbslocal.com/2021/03/01/the-worst-night-of-my-life-man-mourns-grandmother-killed-in-home-explosion-mother-recovering-from-burns/" />
				<style>
					.main-story-wrapper .basicsection { margin-bottom: 20px; }
					.main-story-wrapper .basicsection span strong { display: block; font-size: 18px; margin: 0 auto 15px; }
					.main-story-wrapper .basicsection img { float: none !important; margin: 0 auto 15px; }
					.main-story-wrapper .basicsection br { margin-bottom: 5px; }
				</style>
			<link rel="amphtml" href="https://minnesota.cbslocal.com/2021/03/01/the-worst-night-of-my-life-man-mourns-grandmother-killed-in-home-explosion-mother-recovering-from-burns/amp/">
<script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"NewsArticle","publisher":{"@context":"http:\/\/schema.org","@type":"NewsMediaOrganization","@id":"https:\/\/minnesota.cbslocal.com","url":"https:\/\/minnesota.cbslocal.com","name":"WCCO | CBS Minnesota","foundingDate":"1941-07-01T14:30:00+00:00","logo":{"@type":"ImageObject","url":"https:\/\/minnesota.cbslocal.com\/wp-content\/uploads\/sites\/15909630\/2018\/06\/3_minnesota_cbs4_wcco1.png?w=224"}},"url":"https:\/\/minnesota.cbslocal.com\/2021\/03\/01\/the-worst-night-of-my-life-man-mourns-grandmother-killed-in-home-explosion-mother-recovering-from-burns\/","mainEntityOfPage":{"@type":"WebPage","@id":"https:\/\/minnesota.cbslocal.com\/2021\/03\/01\/the-worst-night-of-my-life-man-mourns-grandmother-killed-in-home-explosion-mother-recovering-from-burns\/"},"headline":"&#8216;The Worst Night Of My Life:&#8217; Man Mourns Grandmother Killed In Home Explosion; Mom Recovering From Burns","description":"A mother and son are working together to heal, one month after a deadly explosion in western Wisconsin. ","image":"https:\/\/minnesota.cbslocal.com\/wp-content\/uploads\/sites\/15909630\/2021\/03\/River-Falls-Home-Explosion.jpg?w=1500","keywords":["Links &amp; Numbers","Local","News","Seen On WCCO-TV","Syndicated Local","Watch + Listen","David Schuman","Home Explosion","Kari Gaustad","Local TV","Martha Gaustad","River Falls News","news","'The Worst Night Of My Life:' Man Mourns Grandmother Killed In Home Explosion; Mom Recovering From Burns"],"datePublished":"2021-03-01T22:12:37+00:00","dateModified":"2021-03-01T22:12:37+00:00","author":{"@type":"Person","name":"David Schuman"},"video":{"@context":"https:\/\/schema.org","@type":"VideoObject","name":"Grandson Mourns Victim Of River Falls Home Explosion","description":"A mother and son are working together to heal one month after a deadly explosion in Wisconsin, reports David Schuman (1:54).\r\nWCCO 4 News At 10 - March 1, 2021","thumbnailUrl":"https:\/\/xheimmxl4gfvfghng2jjos4qhb.gcdn.anvato.net\/anv-iupl\/689\/85C\/68985C2FB01541178088B615D6B87868.jpg?Expires=1709251200&KeyName=mcpkey1&Signature=e8tEUIE5uDo3yDBHNONwSiKe_F8","uploadDate":"2021-03-02","duration":"T1M54S","contentUrl":"https:\/\/minnesota.cbslocal.com\/video\/5351317-grandson-mourns-victim-of-river-falls-home-explosion\/","embedUrl":"https:\/\/minnesota.cbslocal.com\/video\/5351317-grandson-mourns-victim-of-river-falls-home-explosion\/"}}</script>
<script>cbs_lib.load_script("//launch.newsinc.com/js/embed.js");</script><script type="text/javascript">cbs_ads.partners.add("amazon", "3063");if(!window["apstag"]){window["apstag"]={init:function(){window["apstag"]._Q.push(["i",arguments]);},fetchBids:function(){window["apstag"]._Q.push(["f",arguments]);},setDisplayBids:function(){},_Q:[]};}</script>

<script type="text/javascript">cbs_ads.partners.add("sharethrough", true);</script>
<script>cbs_ads.init("4128","CBS.MINN","news",["theworstnightofmylifemanmournsgrandmotherkilledinhomeexplosionmomrecoveringfromburns","post","article","linksandnumbers","local","news","seenonwccotv","syndicatedlocal","watchlisten","davidschuman","homeexplosion","karigaustad","localtv","marthagaustad","riverfallsnews","featuredvideo"],{"page_type":"article"});cbs_ads.refresh.set_timer("2");</script>

<link rel="dns-prefetch" href="//www.googletagmanager.com" />
<script type="text/plain" class="optanon-category-4" src="https://www.googletagmanager.com/gtag/js?id=UA-2438645-63" async></script>
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=UA-2438645-63" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<script type="text/plain" class="optanon-category-4">window.dataLayer=window.dataLayer || [];function gtag(){dataLayer.push(arguments);}gtag("js",new Date());gtag("set",{"dimension1":"links-numbers;local;news;seen-on-wcco-tv;syndicated-local;watch-listen;","dimension2":"article"});gtag("config","UA-2438645-63");</script>

<link rel="icon" href="https://minnesota.cbslocal.com/wp-content/uploads/sites/15909630/2019/07/cropped-minnesota-favicon-512-1.png?w=32" sizes="32x32" />
<link rel="icon" href="https://minnesota.cbslocal.com/wp-content/uploads/sites/15909630/2019/07/cropped-minnesota-favicon-512-1.png?w=192" sizes="192x192" />
<link rel="apple-touch-icon" href="https://minnesota.cbslocal.com/wp-content/uploads/sites/15909630/2019/07/cropped-minnesota-favicon-512-1.png?w=180" />
<meta name="msapplication-TileImage" content="https://minnesota.cbslocal.com/wp-content/uploads/sites/15909630/2019/07/cropped-minnesota-favicon-512-1.png?w=270" />
		<style type="text/css" id="wp-custom-css">
			
.single-post sup {
	vertical-align: super;
}


.lake {
	list-style: none; 
	margin: 0;
}
.mobile-post {display: none;}
		</style>
		<!-- WP Header - End -->

	<meta name="description" content="A mother and son are working together to heal, one month after a deadly explosion in western Wisconsin. " />
<script>//<![CDATA[
		window['_cmpWrapper'] = {
			loaded: function(callback) { cbsoptanon.cmd.push(function(cmp) { cmp.ot.getState(callback); }); },
			getConsentFlag: function(callback) {
				window._cmpWrapper.loaded(function(tar, per, fun, soc) {
					var consent = 0; var consentState = [ per, fun, tar, soc, false ];
					for (var i = 0; i < consentState.length; i++) { if (consentState[i]) { var mask = 1 << i; consent |= mask; } }
					callback(consent);
				});
			}
		}
		//]]></script>

</head>

<body class="post-template-default single single-post postid-1002373 single-format-standard desktop-display-type  and-temp-wide"><div id="wrapper" class="body-wrapper">

<div id="reptile_skin_1" class="cbs-ad-unit ad_gpt cbs-ad-skin" data-ad_location="skin"><script>cbs_load_skin_by_tile(1);</script></div><header id="page-header" class=""><div class="wrapper">

				<a href="https://minnesota.cbslocal.com" id="header-logo"><img src="https://minnesota.cbslocal.com/wp-content/uploads/sites/15909630/2018/06/3_minnesota_cbs4_wcco1.png?w=224" alt="WCCO | CBS Minnesota" /></a>
	
	<nav id="navigation-main" data-item-count="7"><ul class="top"><li class="menu-top-item item-0 section-item w-submenu"><div class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Menu</strong></div></div><div class="submenu"><div class="wrapper">
<section class="items-grid column-count-2 block-type-wpmenu layout-compact aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">Sports</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://minnesota.cbslocal.com/category/sports/" title="Latest" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Latest</strong></div></a><a href="https://minnesota.cbslocal.com/category/sports/vikings/" title="Vikes" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Vikes</strong></div></a><a href="https://minnesota.cbslocal.com/category/sports/twins/" title="Twins" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">Twins</strong></div></a><a href="https://minnesota.cbslocal.com/category/sports/timberwolves/" title="Wolves" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">Wolves</strong></div></a><a href="https://minnesota.cbslocal.com/category/sports/wild/" title="Wild" class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">Wild</strong></div></a><a href="https://minnesota.cbslocal.com/category/sports/lynx/" title="Lynx" class="cbs-thumbnail-link item-5" ><div class="title-wrapper"><strong class="title">Lynx</strong></div></a><a href="https://minnesota.cbslocal.com/category/sports/gophers/" title="U Of M" class="cbs-thumbnail-link item-6" ><div class="title-wrapper"><strong class="title">U Of M</strong></div></a><a href="https://minnesota.cbslocal.com/tag/minnesota-united-fc/" title="United FC" class="cbs-thumbnail-link item-7" ><div class="title-wrapper"><strong class="title">United FC</strong></div></a><a href="https://minnesota.cbslocal.com/category/sports/high-school-sports-rally/" title="Rally" class="cbs-thumbnail-link item-8" ><div class="title-wrapper"><strong class="title">Rally</strong></div></a><a href="https://minnesota.cbslocal.com/tag/pro-golf/" title="Golf" class="cbs-thumbnail-link item-9" ><div class="title-wrapper"><strong class="title">Golf</strong></div></a><a href="https://www.cbssports.com/mlb/" title="MLB" class="cbs-thumbnail-link item-10" ><div class="title-wrapper"><strong class="title">MLB</strong></div></a><a href="https://www.cbssports.com/nba/" title="NBA" class="cbs-thumbnail-link item-11" ><div class="title-wrapper"><strong class="title">NBA</strong></div></a>		</div>
	</section>

<section class="items-grid column-count-2 block-type-wpmenu layout-compact aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">Video</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://minnesota.cbslocal.com/show/wcco-4-news/" title="Video Library" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Video Library</strong></div></a><a href="https://minnesota.cbslocal.com/show/live-wcco-video/" title="Live Video" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Live Video</strong></div></a><a href="https://minnesota.cbslocal.com/show/wcco-4-news/" title="News Videos" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">News Videos</strong></div></a><a href="https://minnesota.cbslocal.com/category/watch-listen/seen-on-wcco-tv/" title="Seen On WCCO-TV" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">Seen On WCCO-TV</strong></div></a><a href="https://minnesota.cbslocal.com/video/category/news-weather-forecast/" title="Weather Forecasts" class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">Weather Forecasts</strong></div></a><a href="https://minnesota.cbslocal.com/video/category/sports/" title="Sports Videos" class="cbs-thumbnail-link item-5" ><div class="title-wrapper"><strong class="title">Sports Videos</strong></div></a><a href="https://minnesota.cbslocal.com/video/category/interviews/" title="WCCO Interviews" class="cbs-thumbnail-link item-6" ><div class="title-wrapper"><strong class="title">WCCO Interviews</strong></div></a>		</div>
	</section>

<section class="items-grid column-count-1 block-type-wpmenu layout-compact aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">Best Of</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://minnesota.cbslocal.com/category/best-of/" title="Best Of" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Best Of</strong></div></a><a href="https://minnesota.cbslocal.com/category/travel/" title="Travel" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Travel</strong></div></a>		</div>
	</section>

<section class="items-grid column-count-1 block-type-wpmenu layout-compact aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">More</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://minnesota.cbslocal.com/station/wcco-tv/" title="Station Info" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Station Info</strong></div></a><a href="https://minnesota.cbslocal.com/category/contests-promotions/" title="Contests &amp; Promotions" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Contests &amp; Promotions</strong></div></a>		</div>
	</section>
</div></div></li><li class="menu-top-item item-1 w-link w-submenu"><a href="https://minnesota.cbslocal.com/category/news/" title="News" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">News</strong></div></a><div class="submenu"><div class="wrapper">
<section class="items-grid column-count-2 block-type-wpmenu layout-compact aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">All News</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://minnesota.cbslocal.com/category/news/local/" title="MN News" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">MN News</strong></div></a><a href="https://minnesota.cbslocal.com/tag/minneapolis/" title="Minneapolis News" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Minneapolis News</strong></div></a><a href="https://minnesota.cbslocal.com/tag/st-paul/" title="St. Paul News" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">St. Paul News</strong></div></a><a href="https://minnesota.cbslocal.com/category/health/" title="HealthWatch" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">HealthWatch</strong></div></a><a href="https://minnesota.cbslocal.com/category/news/consumer-news/" title="Consumer" class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">Consumer</strong></div></a><a href="https://minnesota.cbslocal.com/category/news/crime/" title="Crime" class="cbs-thumbnail-link item-5" ><div class="title-wrapper"><strong class="title">Crime</strong></div></a><a href="https://minnesota.cbslocal.com/category/politics/" title="Politics" class="cbs-thumbnail-link item-6" ><div class="title-wrapper"><strong class="title">Politics</strong></div></a><a href="https://minnesota.cbslocal.com/category/news/business/" title="Business" class="cbs-thumbnail-link item-7" ><div class="title-wrapper"><strong class="title">Business</strong></div></a><a href="https://minnesota.cbslocal.com/category/autos/" title="Autos" class="cbs-thumbnail-link item-8" ><div class="title-wrapper"><strong class="title">Autos</strong></div></a><a href="http://minnesota.cbslocal.com/category/news/entertainment/" title="Entertainment" class="cbs-thumbnail-link item-9" ><div class="title-wrapper"><strong class="title">Entertainment</strong></div></a><a href="https://minnesota.cbslocal.com/category/news/water-cooler/" title="Water Cooler" class="cbs-thumbnail-link item-10" ><div class="title-wrapper"><strong class="title">Water Cooler</strong></div></a><a href="https://minnesota.cbslocal.com/category/only-cbs/" title="Only CBS" class="cbs-thumbnail-link item-11" ><div class="title-wrapper"><strong class="title">Only CBS</strong></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-2 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">Latest News</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://minnesota.cbslocal.com/2021/03/01/vulnerable-minnesotans-crossing-state-lines-for-covid-19-vaccine/" title="COVID In Minnesota: Vulnerable Residents Crossing State Lines For Vaccine" class="cbs-thumbnail-link item-1614661922 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://minnesota.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://minnesota.cbslocal.com/wp-content/uploads/sites/15909630/2021/03/snapshot.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">COVID In Minnesota: Vulnerable Residents Crossing State Lines For Vaccine</strong><em class="description">Vaccinations are simply not coming fast enough for many younger Minnesotans with health issues, and some of them are having more luck crossing state lines.</em></div></a><a href="https://minnesota.cbslocal.com/2021/03/01/how-do-you-get-picked-for-jury-duty/" title="How Do You Get Picked For Jury Duty?" class="cbs-thumbnail-link item-1614660910 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://minnesota.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://minnesota.cbslocal.com/wp-content/uploads/sites/15909630/2021/03/snapshot-2.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">How Do You Get Picked For Jury Duty?</strong><em class="description">When it comes to jury duty, it&#039;s all about the luck of the draw.</em></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-2 block-type-grid layout-4_column aspect-ratio-1-1" id="" >
		<header class="column-header">
				<h4 class="title">Featured Videos</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://minnesota.cbslocal.com/live/cbsn-minnesota/" title="Live WCCO Video" class="cbs-thumbnail-link item-1528751382" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://minnesota.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://minnesota.cbslocal.com/wp-content/uploads/sites/15909630/2019/12/CBSN_MN_LiveStream_1-1.jpg?w=310&#038;h=310&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Live WCCO Video</strong></div></a><a href="http://minnesota.cbslocal.com/video/category/news/" title="News" class="cbs-thumbnail-link item-1480368842" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://minnesota.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://minnesota.cbslocal.com/wp-content/uploads/sites/15909630/2016/03/category_news_500x500.png?w=310&#038;h=310&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">News</strong></div></a>		</div>
	</section>
</div></div></li><li class="menu-top-item item-2 w-link w-submenu"><a href="https://minnesota.cbslocal.com/category/weather/" title="Weather" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Weather</strong></div></a><div class="submenu"><div class="wrapper">
<section class="items-grid column-count-1 block-type-wpmenu layout-compact aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">Weather Links</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://minnesota.cbslocal.com/category/weather/" title="Minnesota Weather" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Minnesota Weather</strong></div></a><a href="https://minnesota.cbslocal.com/twin-cities-area-radar/" title="Live Radar" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Live Radar</strong></div></a><a href="https://minnesota.cbslocal.com/school-closings/" title="School Closings &amp; Delays" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">School Closings &amp; Delays</strong></div></a><a href="https://minnesota.cbslocal.com/2010/11/05/put-chris-shaffer-on-the-spot/" title="On The Spot" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">On The Spot</strong></div></a><a href="https://minnesota.cbslocal.com/join-the-weather-watcher-network/" title="Weather Watcher Network" class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">Weather Watcher Network</strong></div></a><a href="http://apps.cbslocal.com/weather/minnesota/" title="Weather App" class="cbs-thumbnail-link item-5" ><div class="title-wrapper"><strong class="title">Weather App</strong></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-5 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title"><a href="https://minnesota.cbslocal.com/category/weather-stories/">Weather Stories</a></h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://minnesota.cbslocal.com/2021/03/01/minnesotans-enjoy-first-day-of-meteorological-spring/" title="Minnesotans Enjoy First Day Of Meteorological Spring" class="cbs-thumbnail-link item-1614644770 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://minnesota.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://minnesota.cbslocal.com/wp-content/uploads/sites/15909630/2021/03/meteorological-spring.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Minnesotans Enjoy First Day Of Meteorological Spring</strong><em class="description">Monday is the first day of meteorological spring and it doesn&#039;t feel like it, but the rest of this week will be a different story.</em></div></a><a href="https://minnesota.cbslocal.com/2021/02/28/minnesota-weather-narrow-band-drops-snow-throughout-central-minnesota/" title="Minnesota Weather: Narrow Band Drops Snow Throughout Central Minnesota" class="cbs-thumbnail-link item-1614534770 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://minnesota.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://minnesota.cbslocal.com/wp-content/uploads/sites/15909630/2021/02/mwl-022821.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Minnesota Weather: Narrow Band Drops Snow Throughout Central Minnesota</strong><em class="description">After a spring-like day in Minnesota Saturday, we&#039;re back to winter after a fresh batch of snow Sunday.</em></div></a><a href="https://minnesota.cbslocal.com/2021/02/24/family-surprised-to-find-water-in-vans-gas-tank-and-more-surprised-by-how-it-got-there/" title="Family Shocked To Find Water In Gas Tank - And More Shocked By How It Got There" class="cbs-thumbnail-link item-1614225945 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://minnesota.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://minnesota.cbslocal.com/wp-content/uploads/sites/15909630/2021/02/Volkswagon-Camper-Van-With-Water-In-Gas-Tank.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Family Shocked To Find Water In Gas Tank - And More Shocked By How It Got There</strong><em class="description">A Minnesota couple&#039;s day trip to Duluth ended in a costly car repair bill after they discovered their gas tank was full of water.</em></div></a><a href="https://minnesota.cbslocal.com/2021/02/24/walk-like-a-penguin-how-to-avoid-falling-during-refreeze/" title="Walk Like A Penguin: How To Avoid Falling During Refreeze" class="cbs-thumbnail-link item-1614209126 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://minnesota.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://minnesota.cbslocal.com/wp-content/uploads/sites/15909630/2021/02/refreeze.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Walk Like A Penguin: How To Avoid Falling During Refreeze</strong><em class="description">Debbie Luna is one of many Minnesotans who fell victim to the refreeze.</em></div></a><a href="https://minnesota.cbslocal.com/2021/02/22/potholes-to-start-popping-up-following-deep-freeze/" title="Potholes Beginning To Pop Up In Metro Following Deep Freeze" class="cbs-thumbnail-link item-1614034891 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://minnesota.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://minnesota.cbslocal.com/wp-content/uploads/sites/15909630/2021/02/Pothole-Generic.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Potholes Beginning To Pop Up In Metro Following Deep Freeze</strong><em class="description">A deep-freeze like the one we just went through causes ice to expand in the street. When it melts, the water seeps out, taking asphalt with it. That&#039;s when repairs are needed.</em></div></a>		</div>
	</section>
</div></div></li><li class="menu-top-item item-3 w-link w-submenu"><a href="https://minnesota.cbslocal.com/category/sports/" title="Sports" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Sports</strong></div></a><div class="submenu"><div class="wrapper">
<section class="items-grid column-count-2 block-type-wpmenu layout-compact aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">All Sports</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://minnesota.cbslocal.com/category/sports/" title="Latest" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Latest</strong></div></a><a href="https://minnesota.cbslocal.com/category/sports/vikings/" title="Vikes" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Vikes</strong></div></a><a href="https://minnesota.cbslocal.com/category/sports/twins/" title="Twins" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">Twins</strong></div></a><a href="https://minnesota.cbslocal.com/category/sports/timberwolves/" title="Wolves" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">Wolves</strong></div></a><a href="https://minnesota.cbslocal.com/category/sports/wild/" title="Wild" class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">Wild</strong></div></a><a href="https://minnesota.cbslocal.com/category/sports/lynx/" title="Lynx" class="cbs-thumbnail-link item-5" ><div class="title-wrapper"><strong class="title">Lynx</strong></div></a><a href="https://minnesota.cbslocal.com/category/sports/gophers/" title="U Of M" class="cbs-thumbnail-link item-6" ><div class="title-wrapper"><strong class="title">U Of M</strong></div></a><a href="https://minnesota.cbslocal.com/tag/minnesota-united-fc/" title="United FC" class="cbs-thumbnail-link item-7" ><div class="title-wrapper"><strong class="title">United FC</strong></div></a><a href="https://minnesota.cbslocal.com/category/sports/high-school-sports-rally/" title="Rally" class="cbs-thumbnail-link item-8" ><div class="title-wrapper"><strong class="title">Rally</strong></div></a><a href="https://minnesota.cbslocal.com/tag/pro-golf/" title="Golf" class="cbs-thumbnail-link item-9" ><div class="title-wrapper"><strong class="title">Golf</strong></div></a><a href="https://www.cbssports.com/mlb/" title="MLB" class="cbs-thumbnail-link item-10" ><div class="title-wrapper"><strong class="title">MLB</strong></div></a><a href="https://www.cbssports.com/nba/" title="NBA" class="cbs-thumbnail-link item-11" ><div class="title-wrapper"><strong class="title">NBA</strong></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-4 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">Featured Sports</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://minnesota.cbslocal.com/2021/03/01/aaron-rodgers-gives-1-million-to-help-businesses-in-his-california-hometown/" title="Aaron Rodgers Gives $1 Million To Help Businesses In His California Hometown" class="cbs-thumbnail-link item-1614650020 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://minnesota.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://minnesota.cbslocal.com/wp-content/uploads/sites/15909630/2021/01/GettyImages-1280965572.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Aaron Rodgers Gives $1 Million To Help Businesses In His California Hometown</strong><em class="description">These grants will help cover rent for an average of three months or longer, and they also will assist in other operational costs.</em></div></a><a href="https://minnesota.cbslocal.com/2021/03/01/no-pain-position-switch-greet-polanco-at-twins-spring-training/" title="No Pain, Position Switch Greet Polanco At Twins&#039; Spring Training" class="cbs-thumbnail-link item-1614649406 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://minnesota.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://minnesota.cbslocal.com/wp-content/uploads/sites/15909630/2020/08/GettyImages-1265318038.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">No Pain, Position Switch Greet Polanco At Twins&#039; Spring Training</strong><em class="description">After having surgery on his right ankle for the second straight offseason, Jorge Polanco has enjoyed a pain-free start to spring training with the Minnesota Twins.</em></div></a><a href="https://minnesota.cbslocal.com/2021/03/01/ncaa-reveals-logo-for-2022-womens-final-four-in-minneapolis/" title="NCAA Reveals Logo For 2022 Women&#039;s Final Four In Minneapolis" class="cbs-thumbnail-link item-1614621887 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://minnesota.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://minnesota.cbslocal.com/wp-content/uploads/sites/15909630/2021/03/22_WFF_Logo_FC_300_Minneapolis.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">NCAA Reveals Logo For 2022 Women&#039;s Final Four In Minneapolis</strong><em class="description">The logo incorporates iconic Minneapolis locales like the Stone Arch Bridge and the Mississippi River. </em></div></a><a href="https://minnesota.cbslocal.com/2021/02/28/irv-cross-nfl-player-pioneer-black-analyst-dies-at-81/" title="Irv Cross, NFL Player, Pioneer Black Analyst, Dies At 81" class="cbs-thumbnail-link item-1614575881 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://minnesota.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://minnesota.cbslocal.com/wp-content/uploads/sites/15909630/2021/02/GettyImages-137259517.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Irv Cross, NFL Player, Pioneer Black Analyst, Dies At 81</strong><em class="description">Irv Cross, the former NFL defensive back who became the first Black man to work full-time as a sports analyst on national television, died Sunday. He was 81.</em></div></a>		</div>
	</section>
</div></div></li><li class="menu-top-item item-4 w-link w-submenu"><a href="https://minnesota.cbslocal.com/category/best-of/" title="Best Of" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Best Of</strong></div></a><div class="submenu"><div class="wrapper">
<section class="items-grid enable-type-icons column-count-6 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title"><a href="https://minnesota.cbslocal.com/category/best-of/">Latest Headlines</a></h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://minnesota.cbslocal.com/2021/02/25/top-7-minnesota-baking-and-recipe-influencers/" title="Top 7 Minnesota Baking And Recipe Influencers" class="cbs-thumbnail-link item-1614273623 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://minnesota.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://minnesota.cbslocal.com/wp-content/uploads/sites/15909630/2021/02/GettyImages-1187471681.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Top 7 Minnesota Baking And Recipe Influencers</strong><em class="description">Along with the help of Maggie LaMaack, group director for influencer and brand partnerships at Fast Horse, WCCO&#039;s Jason DeRusha has compiled a list of the top seven baking and recipe influencers based in Minnesota.</em></div></a><a href="https://minnesota.cbslocal.com/2021/02/17/americas-least-favorite-pizza-topping-is-not-pineapple/" title="America&#039;s Least Favorite Pizza Topping Is ... Not Pineapple" class="cbs-thumbnail-link item-1613571831 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://minnesota.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://minnesota.cbslocal.com/wp-content/uploads/sites/15909630/2018/10/gettyimages-455318988-e1538490624605.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">America&#039;s Least Favorite Pizza Topping Is ... Not Pineapple</strong><em class="description">A new survey finds, not terribly surprisingly, that America&#039;s #1 favorite pizza topping is pepperoni, followed closely behind by sausage.</em></div></a><a href="https://minnesota.cbslocal.com/2021/02/13/mikes-mix-sooki-mimis-condessa/" title="Mike&#039;s Mix: Sooki &amp; Mimi&#039;s &#039;Condessa&#039;" class="cbs-thumbnail-link item-1613231883 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://minnesota.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://minnesota.cbslocal.com/wp-content/uploads/sites/15909630/2021/02/Screen-Shot-2021-02-13-at-9.57.40-AM.png?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Mike&#039;s Mix: Sooki &amp; Mimi&#039;s &#039;Condessa&#039;</strong><em class="description">Mike Augustyniak recently went to Sooki &amp; Mimi, a new restaurant opened by James Beard Award-winner Ann Kim, to learn their &quot;Condessa&quot; Recipe.</em></div></a><a href="https://minnesota.cbslocal.com/2021/01/15/for-national-bagel-day-jason-derusha-lists-his-top-bagel-spots-in-minnesota/" title="For National Bagel Day, Jason DeRusha Lists His Top Bagel Spots In Minnesota" class="cbs-thumbnail-link item-1610721057 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://minnesota.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://minnesota.cbslocal.com/wp-content/uploads/sites/15909630/2021/01/GettyImages-74944209.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">For National Bagel Day, Jason DeRusha Lists His Top Bagel Spots In Minnesota</strong><em class="description">Craving a bagel on National Bagel Day?</em></div></a><a href="https://minnesota.cbslocal.com/2021/01/06/esquire-magazine-names-the-1-minnesota-restaurant-that-america-cant-afford-to-lose-amid-covid/" title="Esquire Magazine Names The 1 Minnesota Restaurant That America ‘Can’t Afford To Lose’ Amid COVID" class="cbs-thumbnail-link item-1609946769 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://minnesota.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://minnesota.cbslocal.com/wp-content/uploads/sites/15909630/2021/01/GettyImages-1154232913-e1609946994577.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Esquire Magazine Names The 1 Minnesota Restaurant That America ‘Can’t Afford To Lose’ Amid COVID</strong><em class="description">On Wednesday, Gov. Tim Walz is expected to announce a set of relaxed regulations for indoor dining in Minnesota. That being said, the restaurant industry has been devastated by the coronavirus pandemic.</em></div></a><a href="https://minnesota.cbslocal.com/2020/11/19/restaurants-ready-to-step-in-to-cook-your-thanksgiving-meal-this-year/" title="List Of Restaurants Ready To Step In To Cook Your Thanksgiving Meal This Year" class="cbs-thumbnail-link item-1605806730 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://minnesota.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://minnesota.cbslocal.com/wp-content/uploads/sites/15909630/2020/10/Mason-Jar-Kitchen-Thanksgiving-Dinner.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">List Of Restaurants Ready To Step In To Cook Your Thanksgiving Meal This Year</strong><em class="description">Thanksgiving is a few weeks away, and with COVID-19 cases still on the rise, it&#039;s likely most are going to opt for a smaller-scale Thanksgiving dinner in a much smaller gathering.</em></div></a>		</div>
	</section>
</div></div></li><li class="menu-top-item item-5 w-link w-submenu"><a href="https://minnesota.cbslocal.com/video/" title="Video" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Video</strong></div></a><div class="submenu"><div class="wrapper">
<section class="items-grid enable-type-icons column-count-6 block-type-grid layout-4_column aspect-ratio-1-1" id="" >
		<header class="column-header">
				<h4 class="title">Featured Videos</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://minnesota.cbslocal.com/live/cbsn-minnesota/" title="Live WCCO Video" class="cbs-thumbnail-link item-1528751382" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://minnesota.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://minnesota.cbslocal.com/wp-content/uploads/sites/15909630/2019/12/CBSN_MN_LiveStream_1-1.jpg?w=310&#038;h=310&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Live WCCO Video</strong></div></a><a href="http://minnesota.cbslocal.com/video/category/interviews/" title="Interviews" class="cbs-thumbnail-link item-1480453891" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://minnesota.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://minnesota.cbslocal.com/wp-content/uploads/sites/15909630/2016/11/category_interviews_500x500.png?w=310&#038;h=310&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Interviews</strong></div></a><a href="http://minnesota.cbslocal.com/video/category/news-politics/" title="Politics" class="cbs-thumbnail-link item-1480453053" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://minnesota.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://minnesota.cbslocal.com/wp-content/uploads/sites/15909630/2016/03/category_politics_500x500.png?w=310&#038;h=310&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Politics</strong></div></a><a href="http://minnesota.cbslocal.com/video/category/sports/" title="Sports" class="cbs-thumbnail-link item-1480452972" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://minnesota.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://minnesota.cbslocal.com/wp-content/uploads/sites/15909630/2016/03/category_sports_500x500.png?w=310&#038;h=310&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Sports</strong></div></a><a href="http://minnesota.cbslocal.com/video/category/news-weather-forecast/" title="Weather" class="cbs-thumbnail-link item-1480452823" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://minnesota.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://minnesota.cbslocal.com/wp-content/uploads/sites/15909630/2016/03/category_weather_500x500.png?w=310&#038;h=310&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Weather</strong></div></a><a href="http://minnesota.cbslocal.com/video/category/news/" title="News" class="cbs-thumbnail-link item-1480452426" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://minnesota.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://minnesota.cbslocal.com/wp-content/uploads/sites/15909630/2016/03/category_news_500x500.png?w=310&#038;h=310&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">News</strong></div></a>		</div>
	</section>
</div></div></li><li class="menu-top-item item-6 w-submenu"><div class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Info &amp; More</strong></div></div><div class="submenu"><div class="wrapper">
<section class="items-grid enable-type-icons column-count-2 block-type-grid layout-4_column aspect-ratio-1-1" id="" >
		<header class="column-header">
				<h4 class="title">Station Info and CBS Entertainment</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://minnesota.cbslocal.com/station/wcco-tv/" title="Station Info" class="cbs-thumbnail-link item-1530555483" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://minnesota.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://minnesota.cbslocal.com/wp-content/uploads/sites/15909630/2016/11/wcco_videoplayer_generic.png?w=310&#038;h=310&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Station Info</strong></div></a><a href="https://minnesota.cbslocal.com/category/only-cbs/" title="Only CBS" class="cbs-thumbnail-link item-1530471604" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://minnesota.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://minnesota.cbslocal.com/wp-content/uploads/sites/15909630/2018/07/onlycbs_640x360.png?w=310&#038;h=310&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Only CBS</strong></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-2 block-type-grid layout-4_column aspect-ratio-1-1" id="" >
		<header class="column-header">
				<h4 class="title"><a href="https://minnesota.cbslocal.com/category/health/coronavirus/">COVID-19 Resources</a></h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="http://minnesota.cbslocal.com/community/" title="COVID-19 Community" class="cbs-thumbnail-link item-1585779613" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://minnesota.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://minnesota.cbslocal.com/wp-content/uploads/sites/15909630/2020/04/Covid19_Community_Resources2.jpg?w=310&#038;h=310&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">COVID-19 Community</strong></div></a><a href="https://minnesota.cbslocal.com/coronavirus-resources/" title="COVID-19 Resources" class="cbs-thumbnail-link item-1584383117" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://minnesota.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://minnesota.cbslocal.com/wp-content/uploads/sites/15909630/2020/07/Covid19_Resources_310x310.jpg?w=310&#038;h=310&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">COVID-19 Resources</strong></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-2 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title"><a href="https://minnesota.cbslocal.com/category/watch-listen/wcco-tv-shows/good-question/">Good Question</a></h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://minnesota.cbslocal.com/2021/03/01/how-do-you-get-picked-for-jury-duty/" title="How Do You Get Picked For Jury Duty?" class="cbs-thumbnail-link item-1614660910 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://minnesota.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://minnesota.cbslocal.com/wp-content/uploads/sites/15909630/2021/03/snapshot-2.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">How Do You Get Picked For Jury Duty?</strong><em class="description">When it comes to jury duty, it&#039;s all about the luck of the draw.</em></div></a><a href="https://minnesota.cbslocal.com/2021/02/25/where-does-minnesotas-power-come-from/" title="Where Does Minnesota&#039;s Power Come From?" class="cbs-thumbnail-link item-1614313163 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://minnesota.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://minnesota.cbslocal.com/wp-content/uploads/sites/15909630/2021/02/Solar-Farm.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Where Does Minnesota&#039;s Power Come From?</strong><em class="description">Minnesota&#039;s biggest electric utilities - Xcel Energy and Minnesota Power - have pledged to go carbon-free by 2050.</em></div></a>		</div>
	</section>
</div></div></li></ul></nav>
	<a id="live" class="v2" href="https://minnesota.cbslocal.com/live/" data-source_url="https://feeds-cbsn.cbsnews.com/2.0/rundown/?partner=cbsnsite&#038;edition=CBSN-MIN"><span class="button"><strong>CBSN Minnesota</strong><em>Watch Now</em></span></a>
	<a href="http://minnesota.cbslocal.com/category/weather/" id="info-weather"><div id="weather-widget-sticker" class="embed-item embed-weather weather-widget-wrap" ><div class="wrapper">
<wx-widget type="current-conditions" latitude="44.966009" longitude="-93.169929" header="false"></wx-widget>
</div></div></a>
	<div id="info-search"><form action="https://minnesota.cbslocal.com/search/" class="form"><input type="text" class="query" name="q" id="s" size="31" placeholder="Search..." /><input type="reset" class="reset" value="Reset" /><input type="submit" class="submit" value="&#xf002" /></form><span class="open-close" onclick="jQuery(document).ready(function(){jQuery('#info-search').toggleClass('open');});"></span></div>
</div></header>		<section class="page-ad-container page-pencil-ad-container-top">
			<div id="reptile_1_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper"><span id="ad_1"><div id="reptile_1" class="ad-block" data-ad_size="[[970,250],[970,66],[728,90]]" data-ad_location="top"><script>cbs_load_ad_by_tile("1");</script></div></span></div>		</section>
		
<div id="page-content" class="main-white page-block-container and-w-sidebar">
<header id="page-rubric" class="">

			<div class="banner-title-wrapper">
							<h1 class="title">&#8216;The Worst Night Of My Life:&#8217; Man Mourns Grandmother Killed In Home Explosion; Mom Recovering From Burns</h1>
					</div>
	
	
	
	
	
</header>
<section class="page-columns"><section class="page-column three-column" id="article-entry-date-and-tags"><div class="column-header"><span class="post-personality">By <a href="https://minnesota.cbslocal.com/personality/david-schuman">David Schuman</a></span><time class="post-date">March 1, 2021 at 10:12 pm</time><div class="column-header-metadata"><strong>Filed Under:</strong><span><a href="https://minnesota.cbslocal.com/tag/david-schuman/">David Schuman</a>, <a href="https://minnesota.cbslocal.com/tag/home-explosion/">Home Explosion</a>, <a href="https://minnesota.cbslocal.com/tag/kari-gaustad/">Kari Gaustad</a>, <a href="https://minnesota.cbslocal.com/tag/local-tv/">Local TV</a>, <a href="https://minnesota.cbslocal.com/tag/martha-gaustad/">Martha Gaustad</a>, <a href="https://minnesota.cbslocal.com/tag/river-falls-news/">River Falls News</a></div></div></section><section id="column_block_1" class="page-column and-content-column two-column"><div class="column-item story" id="main-story"><section class="column-item media-type-anvato  ratio-display close-btn" id="featured-media"><div id="floating-player-container" class="video-wrapper anvato"><div class="anvato-iframe-wrapper"><div id="p0"></div></div><script>cbsoptanon.onScriptsReady(function(cmp){cmp.ot.targetingAllowed(function(a){if(a) AnvatoPlayer("p0").init({"mcp":"cbs","width":"100%","height":"100%","video":"5351317","autoplay":true,"titleVisible":false,"accessKey":"5VD6Eyd6djewbCmNwBFnsJj17YAvGRwl","accessControl":{"preview":false},"pInstance":"p0","plugins":{"heartbeat":{"account":"cbslocal-global-unified","publisherId":"cbslocal","jobId":"sc_va","marketingCloudId":"823BA0335567497F7F000101@AdobeOrg","trackingServer":"cbsdigitalmedia.hb.omtrdc.net","customTrackingServer":"cbsdigitalmedia.d1.sc.omtrdc.net","chapterTracking":false,"version":"1.5"},"comscore":{"clientId":"3000023","c3":"Minnesota.cbslocal.com"},"dfp":{"clientSide":{"adTagUrl":"http:\/\/pubads.g.doubleclick.net\/gampad\/ads?sz=2x2&iu=\/4128\/cbs.minn&ciu_szs&impl=s&gdfp_req=1&env=vp&output=xml_vast2&unviewed_position_start=1&url=[referrer_url]&description_url=[description_url]&correlator=[timestamp]","keyValues":{"categories":"[[CATEGORIES]]","program":"[[PROGRAM_NAME]]","siteSection":"featured"}}},"moat":{"clientSide":{"partnerCode":"cbslocalanvatovideo181732609431"}}},"shareLink":"https:\/\/cbsloc.al\/3uMSVqj","video-type":"featured","token":"default","expectPreroll":true,"expectPrerollTimeout":5});});});</script></div></section>
<div id="article-livedvr-block" class="embed-item embed-ottplayer" ><div class="wrapper">
<span class="adhesive-wrapper"><div class="logo-container"><a href="https://minnesota.cbslocal.com/live/cbsn-minnesota/"><img src="https://minnesota.cbslocal.com/wp-content/uploads/sites/15909630/2019/12/CBSN-WHITE-H-Minnesota.png?w=420"/></a></div></span><div class="dvr-container"><div class="dvr-wrapper embed-item embed-slider w-action-manual" data-up_url="https://feeds-cbsn.cbsnews.com/2.0/rundown/?partner=cbsnsite&#038;edition=CBSN-MIN" data-channel_slug="cbsn-minnesota" data-w-live="true" data-dvr-live-thumb_url="https://minnesota.cbslocal.com/wp-content/uploads/sites/15909630/2019/12/Minnesota-WatchLive.png?w=310&#038;h=174&#038;crop=1"></div></div><script>jQuery(function($){jQuery(window).load(function(){cbs_embed_ottplayer.update_dvr("#article-livedvr-block .dvr-container .dvr-wrapper");setInterval(function(){cbs_embed_ottplayer.update_dvr("#article-livedvr-block .dvr-container .dvr-wrapper");},30000);});});</script>
</div></div><div class="main-story-wrapper"><p><b>MINNEAPOLIS (WCCO)</b> &#8212; A mother and son are working together to heal, one month after a deadly explosion in western Wisconsin. </p>
<p><a href="https://cbsloc.al/2L8dhYS" rel="nofollow">The blast leveled a home in River Falls on Feb. 1</a>, killing a 75-year-old woman and sending her daughter to the hospital.</p>
<div id="attachment_1002374" style="width: 430px" class="wp-caption aligncenter"><img aria-describedby="caption-attachment-1002374" loading="lazy" src="https://minnesota.cbslocal.com/wp-content/uploads/sites/15909630/2021/03/Home-Explosion-Folo-Pkg-10-030121_0301T213805..jpg" alt="" width="420" height="236" class="size-full wp-image-1002374" srcset="https://minnesota.cbslocal.com/wp-content/uploads/sites/15909630/2021/03/Home-Explosion-Folo-Pkg-10-030121_0301T213805..jpg 1920w, https://minnesota.cbslocal.com/wp-content/uploads/sites/15909630/2021/03/Home-Explosion-Folo-Pkg-10-030121_0301T213805..jpg?resize=300,169 300w, https://minnesota.cbslocal.com/wp-content/uploads/sites/15909630/2021/03/Home-Explosion-Folo-Pkg-10-030121_0301T213805..jpg?resize=768,432 768w, https://minnesota.cbslocal.com/wp-content/uploads/sites/15909630/2021/03/Home-Explosion-Folo-Pkg-10-030121_0301T213805..jpg?resize=1024,576 1024w, https://minnesota.cbslocal.com/wp-content/uploads/sites/15909630/2021/03/Home-Explosion-Folo-Pkg-10-030121_0301T213805..jpg?resize=1536,864 1536w, https://minnesota.cbslocal.com/wp-content/uploads/sites/15909630/2021/03/Home-Explosion-Folo-Pkg-10-030121_0301T213805..jpg?resize=640,360 640w, https://minnesota.cbslocal.com/wp-content/uploads/sites/15909630/2021/03/Home-Explosion-Folo-Pkg-10-030121_0301T213805..jpg?resize=310,174 310w, https://minnesota.cbslocal.com/wp-content/uploads/sites/15909630/2021/03/Home-Explosion-Folo-Pkg-10-030121_0301T213805..jpg?resize=1138,640 1138w, https://minnesota.cbslocal.com/wp-content/uploads/sites/15909630/2021/03/Home-Explosion-Folo-Pkg-10-030121_0301T213805..jpg?resize=1820,1024 1820w, https://minnesota.cbslocal.com/wp-content/uploads/sites/15909630/2021/03/Home-Explosion-Folo-Pkg-10-030121_0301T213805..jpg?resize=320,180 320w, https://minnesota.cbslocal.com/wp-content/uploads/sites/15909630/2021/03/Home-Explosion-Folo-Pkg-10-030121_0301T213805..jpg?resize=620,349 620w, https://minnesota.cbslocal.com/wp-content/uploads/sites/15909630/2021/03/Home-Explosion-Folo-Pkg-10-030121_0301T213805..jpg?resize=1500,844 1500w" sizes="(max-width: 420px) 100vw, 420px" /><p id="caption-attachment-1002374" class="wp-caption-text">Kari Gaustad, Martha Gaustad and an unidentified woman (credit: Jared Gaustad)</p></div>
<p>Jared Gaustad&#8217;s grandmother, Martha Gaustad, died in the explosion.</p>
<p>&#8220;Pretty much the worst night of my life,&#8221; Gaustad said. &#8220;She always picked me up, brought me out to eat. She was just a really nice lady overall, and I miss her a lot. And my mom gets her strength from her.&#8221;</p>
<p>Gaustad&#8217;s mother, Kari Gaustad, was also inside. She told her son she turned on a space heater and it felt like the air was on fire. Then there were a couple thuds, and next thing she knew she was in the yard with a piece of drywall on top of her. Kari&#8217;s now out of the hospital, continuing to recover from burns all over her body.</p>
<div id="attachment_1002379" style="width: 430px" class="wp-caption aligncenter"><img aria-describedby="caption-attachment-1002379" loading="lazy" src="https://minnesota.cbslocal.com/wp-content/uploads/sites/15909630/2021/03/River-Falls-Home-Explosion.jpg" alt="" width="420" height="236" class="size-full wp-image-1002379" srcset="https://minnesota.cbslocal.com/wp-content/uploads/sites/15909630/2021/03/River-Falls-Home-Explosion.jpg 1920w, https://minnesota.cbslocal.com/wp-content/uploads/sites/15909630/2021/03/River-Falls-Home-Explosion.jpg?resize=300,169 300w, https://minnesota.cbslocal.com/wp-content/uploads/sites/15909630/2021/03/River-Falls-Home-Explosion.jpg?resize=768,432 768w, https://minnesota.cbslocal.com/wp-content/uploads/sites/15909630/2021/03/River-Falls-Home-Explosion.jpg?resize=1024,576 1024w, https://minnesota.cbslocal.com/wp-content/uploads/sites/15909630/2021/03/River-Falls-Home-Explosion.jpg?resize=1536,864 1536w, https://minnesota.cbslocal.com/wp-content/uploads/sites/15909630/2021/03/River-Falls-Home-Explosion.jpg?resize=640,360 640w, https://minnesota.cbslocal.com/wp-content/uploads/sites/15909630/2021/03/River-Falls-Home-Explosion.jpg?resize=310,174 310w, https://minnesota.cbslocal.com/wp-content/uploads/sites/15909630/2021/03/River-Falls-Home-Explosion.jpg?resize=1138,640 1138w, https://minnesota.cbslocal.com/wp-content/uploads/sites/15909630/2021/03/River-Falls-Home-Explosion.jpg?resize=1820,1024 1820w, https://minnesota.cbslocal.com/wp-content/uploads/sites/15909630/2021/03/River-Falls-Home-Explosion.jpg?resize=320,180 320w, https://minnesota.cbslocal.com/wp-content/uploads/sites/15909630/2021/03/River-Falls-Home-Explosion.jpg?resize=620,349 620w, https://minnesota.cbslocal.com/wp-content/uploads/sites/15909630/2021/03/River-Falls-Home-Explosion.jpg?resize=1500,844 1500w" sizes="(max-width: 420px) 100vw, 420px" /><p id="caption-attachment-1002379" class="wp-caption-text">(credit: CBS)</p></div>
<p>&#8220;She&#8217;s healing really fast, so that&#8217;s all that I&#8217;m asking for really is she gets better,&#8221; Gaustad said.</p>
<p>The family also lost two dogs in the tragic explosion, a chocolate lab named Lola and a golden retriever named Rosie. The night it happened, neighbors rushed into the house to try to save Martha. Gaustad was at a friend&#8217;s house at the time.</p>
<p>&#8220;I&#8217;ve already talked to most of them and expressed my gratitude,&#8221; he said. &#8220;There&#8217;s no words &#8230; I can say or how I feel about what everybody did for me and my family. It means the world to me.&#8221;</p>
<div id="attachment_1002375" style="width: 430px" class="wp-caption aligncenter"><img aria-describedby="caption-attachment-1002375" loading="lazy" src="https://minnesota.cbslocal.com/wp-content/uploads/sites/15909630/2021/03/son.jpg" alt="" width="420" height="236" class="size-full wp-image-1002375" srcset="https://minnesota.cbslocal.com/wp-content/uploads/sites/15909630/2021/03/son.jpg 1920w, https://minnesota.cbslocal.com/wp-content/uploads/sites/15909630/2021/03/son.jpg?resize=300,169 300w, https://minnesota.cbslocal.com/wp-content/uploads/sites/15909630/2021/03/son.jpg?resize=768,432 768w, https://minnesota.cbslocal.com/wp-content/uploads/sites/15909630/2021/03/son.jpg?resize=1024,576 1024w, https://minnesota.cbslocal.com/wp-content/uploads/sites/15909630/2021/03/son.jpg?resize=1536,864 1536w, https://minnesota.cbslocal.com/wp-content/uploads/sites/15909630/2021/03/son.jpg?resize=640,360 640w, https://minnesota.cbslocal.com/wp-content/uploads/sites/15909630/2021/03/son.jpg?resize=310,174 310w, https://minnesota.cbslocal.com/wp-content/uploads/sites/15909630/2021/03/son.jpg?resize=1138,640 1138w, https://minnesota.cbslocal.com/wp-content/uploads/sites/15909630/2021/03/son.jpg?resize=1820,1024 1820w, https://minnesota.cbslocal.com/wp-content/uploads/sites/15909630/2021/03/son.jpg?resize=320,180 320w, https://minnesota.cbslocal.com/wp-content/uploads/sites/15909630/2021/03/son.jpg?resize=620,349 620w, https://minnesota.cbslocal.com/wp-content/uploads/sites/15909630/2021/03/son.jpg?resize=1500,844 1500w" sizes="(max-width: 420px) 100vw, 420px" /><p id="caption-attachment-1002375" class="wp-caption-text">Jared Gaustad (credit: CBS)</p></div>
<p>The Gaustads are now searching for a new place, and they want to stay near River Falls to be close to family and friends. <a href="https://www.gofundme.com/f/house-explosion-leaves-family-in-desperate-need?utm_source=facebook&amp;utm_medium=social&amp;utm_campaign=p_cp%20share-sheet&amp;fbclid=IwAR2mwGyFCnjojB8RvuBCxaGLdt2TwaT9xZOPQ_fUjfWL2-4ok6aOa-Ghq4A" rel="nofollow">Click here to help their family</a>.</p>
<p>The River Falls deputy fire chief told WCCO that investigators couldn&#8217;t pinpoint what caused the explosion.</p>
<div id="shortcode-listicle-986114" class="shortcode listicle-shortcode txt_listicle">&nbsp;
<p style="text-align: left"><b data-stringify-type="bold">More On </b><b data-stringify-type="bold">WCCO.com</b><b data-stringify-type="bold">:</b></p>

<ul>
 	<li><a href="https://minnesota.cbslocal.com/2021/02/27/minneapolis-to-hire-6-influencers-to-spread-city-approved-messaging-to-public-during-derek-chauvin-trial/">Minneapolis To Hire 6 ‘Influencers’ To Spread City-Approved Messaging To Public During Derek Chauvin Trial</a></li>
 	<li><a href="https://minnesota.cbslocal.com/2021/02/28/thief-steals-car-with-2-year-old-child-inside-in-minneapolis/">Minneapolis Police: Raylene Childs, 2, Found Safe After AMBER Alert Issued</a></li>
 	<li><a href="https://minnesota.cbslocal.com/2021/02/27/2-killed-deputy-injured-wadena-county-shootout/">2 Killed, Deputy Injured In Wadena County Shootout</a></li>
 	<li><a href="https://minnesota.cbslocal.com/2021/02/27/minnesotans-argue-state-not-appropriately-prioritizing-vaccines-for-those-with-underlying-conditions/">Minnesotans Argue State Not Appropriately Prioritizing Vaccines For Those With Underlying Conditions</a></li>
</ul></div>
<div class="social-buttons">
	<div class="social-media-container vertical">
					<div class="social-share-items addthis_toolbox addthis_default_style addthis_32x32_style">
				<span><a class="addthis_button_facebook"  addthis:url="https://cbsloc.al/3uMSVqj"></a><a class="addthis_button_twitter"  addthis:url="https://cbsloc.al/3uMSVqj"></a><a href="#" class="addthis_button_linkedin"></a><a href="#" class="addthis_button_reddit"></a><a class="addthis_button_compact"  addthis:url="https://cbsloc.al/3uMSVqj"></a></span>
			</div>
		
			</div>
</div></div></div><div id="app-promo-wrapper"><a href="https://apps.cbslocal.com/minnesota/" data-ios="https://apps.apple.com/us/app/cbs-minnesota/id1511233594" data-android="https://play.google.com/store/apps/details?id=com.wcco.android.news" target="_blank"><img src="https://minnesota.cbslocal.com/wp-content/themes/cbs-local/images/app-promos/minnesota.jpg"/></a></div><div id="personality-credits-container" class="embed-item embed-list" ><div class="wrapper">
<header class="partblock__title block-head-wrapper"><h4 class="title"><span>David </span> Schuman</h4></header><div class="block-content-wrapper and-list layout-catalog aspect-ratio-16-9"><div class="cbs-thumbnail-link item-0" id="personality-credits" data-social-links="{&quot;twitter_url&quot;:&quot;http:\/\/twitter.com\/david_schuman&quot;,&quot;facebook_url&quot;:&quot;http:\/\/facebook.com\/davidschumantv&quot;,&quot;instagram_url&quot;:&quot;http:\/\/www.instagram.com\/david_schuman\/&quot;,&quot;email_address&quot;:&quot;dsschuman@wcco.com&quot;}" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://minnesota.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://minnesota.cbslocal.com/wp-content/uploads/sites/15909630/2020/08/WEB-David-Schuman.jpg?w=640&#038;h=360&#038;crop=1"></span></div><div class="title-wrapper"><em class="description">David joined the WCCO team in April 2020, previously working at WDJT in Milwaukee. Prior to that, he worked in Las Vegas.</em><a href="https://minnesota.cbslocal.com/personality/david-schuman/" id="more-from-personality"><span>More from</span> <strong>David Schuman</strong></a></div></div></div>
</div></div><div id="reptile_30_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper partner-container partner-sharethrough"><span id="ad_30"><div id="reptile_30" class="ad-block" data-ad_size="[[1,5]]" data-ad_location="partner-injected" data-ad_targets={"strnativekey":"d3da4d50"}><script>cbs_load_ad_by_tile("30");</script></div></span></div><div class="partner-container partner-taboola"><div id="taboola-block-2"></div></div></section><aside class="sidebar right-bar" rel="modular+"><div id="reptile_2_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper"><span id="ad_2"><div id="reptile_2" class="ad-block" data-ad_size="[[300,250],[300,600],[300,1050]]" data-ad_location="top"><script>cbs_load_ad_by_tile("2");</script></div></span></div><div id="" class="block sidebar-widget widget_cbs_follow_us_widget"><h3 class="title">Follow Us</h3>
		<div class="widget-content-wrapper">
			<a href="http://facebook.com/CBSMinnesota" target="_blank" title="facebook_url" class="cbs-thumbnail-link facebook_url" ><div class="title-wrapper"><strong class="title">facebook_url</strong></div></a><a href="http://twitter.com/wcco" target="_blank" title="twitter_url" class="cbs-thumbnail-link twitter_url" ><div class="title-wrapper"><strong class="title">twitter_url</strong></div></a><a href="http://youtube.com/wcco" target="_blank" title="youtube_url" class="cbs-thumbnail-link youtube_url" ><div class="title-wrapper"><strong class="title">youtube_url</strong></div></a><a href="http://instagram.com/wcco" target="_blank" title="instagram_url" class="cbs-thumbnail-link instagram_url" ><div class="title-wrapper"><strong class="title">instagram_url</strong></div></a><a href="https://www.reddit.com/user/cbsminnesota" target="_blank" title="reddit_url" class="cbs-thumbnail-link reddit_url" ><div class="title-wrapper"><strong class="title">reddit_url</strong></div></a><a href="https://www.linkedin.com/company/wcco-tv/" target="_blank" title="linkedin_url" class="cbs-thumbnail-link linkedin_url" ><div class="title-wrapper"><strong class="title">linkedin_url</strong></div></a>		</div>

		</div><div id="" class="block sidebar-widget widget_cbs_newsletter_widget"><h3 class="title">Our | Newsletter</h3><div class="widget-content-wrapper"><iframe id="newsletter-widget-iframe" width="300" src="https://bh-ems-static-content.s3.amazonaws.com/cbsi/2706/cbs_local_form_f.html?market=minnesota"></iframe></div></div><div id="" class="block sidebar-widget widget_top-posts"><h3 class="title"><span>Most </span> Viewed</h3><ul class='widgets-list-layout no-grav'>
					<li>
						<a href="https://minnesota.cbslocal.com/2021/03/01/minnesota-food-distribution-company-issues-nationwide-recall-over-bacteria-concerns/" title="Minnesota Distribution Company Issues Nationwide Recall On Taco Products Over Bacteria Concerns" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i2.wp.com/minnesota.cbslocal.com/wp-content/uploads/sites/15909630/2021/03/GettyImages-637801286.jpg?resize=55%2C55&#038;ssl=1" alt="Minnesota Distribution Company Issues Nationwide Recall On Taco Products Over Bacteria Concerns" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://minnesota.cbslocal.com/2021/03/01/minnesota-food-distribution-company-issues-nationwide-recall-over-bacteria-concerns/" title="Minnesota Distribution Company Issues Nationwide Recall On Taco Products Over Bacteria Concerns" class="bump-view" data-bump-view="tp">Minnesota Distribution Company Issues Nationwide Recall On Taco Products Over Bacteria Concerns</a>
							</div>
													</li>
										<li>
						<a href="https://minnesota.cbslocal.com/2021/02/28/thief-steals-car-with-2-year-old-child-inside-in-minneapolis/" title="Minneapolis Police: Raylene Childs, 2, Found Safe After AMBER Alert Issued" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i2.wp.com/minnesota.cbslocal.com/wp-content/uploads/sites/15909630/2021/02/Raylene-Childs.jpg?resize=55%2C55&#038;ssl=1" alt="Minneapolis Police: Raylene Childs, 2, Found Safe After AMBER Alert Issued" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://minnesota.cbslocal.com/2021/02/28/thief-steals-car-with-2-year-old-child-inside-in-minneapolis/" title="Minneapolis Police: Raylene Childs, 2, Found Safe After AMBER Alert Issued" class="bump-view" data-bump-view="tp">Minneapolis Police: Raylene Childs, 2, Found Safe After AMBER Alert Issued</a>
							</div>
													</li>
										<li>
						<a href="https://minnesota.cbslocal.com/2021/02/28/shes-lucky-to-be-alive-fernando-juarez-charged-with-assaulting-girlfriends-toddler/" title="&#039;She&#039;s Lucky To Be Alive&#039;: Fernando Juarez Charged With Assaulting Girlfriend&#039;s Toddler" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i0.wp.com/minnesota.cbslocal.com/wp-content/uploads/sites/15909630/2021/02/snapshot-7.jpg?resize=55%2C55&#038;ssl=1" alt="&#039;She&#039;s Lucky To Be Alive&#039;: Fernando Juarez Charged With Assaulting Girlfriend&#039;s Toddler" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://minnesota.cbslocal.com/2021/02/28/shes-lucky-to-be-alive-fernando-juarez-charged-with-assaulting-girlfriends-toddler/" title="&#039;She&#039;s Lucky To Be Alive&#039;: Fernando Juarez Charged With Assaulting Girlfriend&#039;s Toddler" class="bump-view" data-bump-view="tp">&#039;She&#039;s Lucky To Be Alive&#039;: Fernando Juarez Charged With Assaulting Girlfriend&#039;s Toddler</a>
							</div>
													</li>
										<li>
						<a href="https://minnesota.cbslocal.com/2021/02/27/minneapolis-to-hire-6-influencers-to-spread-city-approved-messaging-to-public-during-derek-chauvin-trial/" title="Minneapolis To Hire 6 &#039;Influencers&#039; To Spread City-Approved Messaging To Public During Derek Chauvin Trial" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i2.wp.com/minnesota.cbslocal.com/wp-content/uploads/sites/15909630/2020/06/Derek-Chauvin-Mug-4.jpg?resize=55%2C55&#038;ssl=1" alt="Minneapolis To Hire 6 &#039;Influencers&#039; To Spread City-Approved Messaging To Public During Derek Chauvin Trial" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://minnesota.cbslocal.com/2021/02/27/minneapolis-to-hire-6-influencers-to-spread-city-approved-messaging-to-public-during-derek-chauvin-trial/" title="Minneapolis To Hire 6 &#039;Influencers&#039; To Spread City-Approved Messaging To Public During Derek Chauvin Trial" class="bump-view" data-bump-view="tp">Minneapolis To Hire 6 &#039;Influencers&#039; To Spread City-Approved Messaging To Public During Derek Chauvin Trial</a>
							</div>
													</li>
										<li>
						<a href="https://minnesota.cbslocal.com/2021/03/01/stimulus-check-update-unemployment-insurance-child-tax-credit-covid/" title="Third Stimulus Check: How Could The Economic Relief Package Put More Money In Your Pocket?" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i1.wp.com/minnesota.cbslocal.com/wp-content/uploads/sites/15909630/2021/03/joe-biden-3-1.jpg?resize=55%2C55&#038;ssl=1" alt="Third Stimulus Check: How Could The Economic Relief Package Put More Money In Your Pocket?" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://minnesota.cbslocal.com/2021/03/01/stimulus-check-update-unemployment-insurance-child-tax-credit-covid/" title="Third Stimulus Check: How Could The Economic Relief Package Put More Money In Your Pocket?" class="bump-view" data-bump-view="tp">Third Stimulus Check: How Could The Economic Relief Package Put More Money In Your Pocket?</a>
							</div>
													</li>
										<li>
						<a href="https://minnesota.cbslocal.com/2021/03/01/dept-of-human-rights-settles-with-eagan-company-that-wouldnt-hire-women/" title="Dept. Of Human Rights Settles With Eagan Company That Wouldn&#039;t Hire Women" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i2.wp.com/minnesota.cbslocal.com/wp-content/uploads/sites/15909630/2017/12/mn-dept-of-human-rights.jpg?resize=55%2C55&#038;ssl=1" alt="Dept. Of Human Rights Settles With Eagan Company That Wouldn&#039;t Hire Women" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://minnesota.cbslocal.com/2021/03/01/dept-of-human-rights-settles-with-eagan-company-that-wouldnt-hire-women/" title="Dept. Of Human Rights Settles With Eagan Company That Wouldn&#039;t Hire Women" class="bump-view" data-bump-view="tp">Dept. Of Human Rights Settles With Eagan Company That Wouldn&#039;t Hire Women</a>
							</div>
													</li>
										<li>
						<a href="https://minnesota.cbslocal.com/2021/02/28/2-dead-deputy-and-officer-shot-in-wadena-county/" title="2 Suspects Dead, Deputy And Officer Shot In Wadena County Shootout" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i1.wp.com/minnesota.cbslocal.com/wp-content/uploads/sites/15909630/2021/02/Wadena-County-Sheriff-Shooting.jpg?resize=55%2C55&#038;ssl=1" alt="2 Suspects Dead, Deputy And Officer Shot In Wadena County Shootout" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://minnesota.cbslocal.com/2021/02/28/2-dead-deputy-and-officer-shot-in-wadena-county/" title="2 Suspects Dead, Deputy And Officer Shot In Wadena County Shootout" class="bump-view" data-bump-view="tp">2 Suspects Dead, Deputy And Officer Shot In Wadena County Shootout</a>
							</div>
													</li>
										<li>
						<a href="https://minnesota.cbslocal.com/2021/02/26/stimulus-check-update-how-much-1400-covid-relief-payment/" title="Stimulus Check Latest: Will Your Next Relief Payment Be $1,400?" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i2.wp.com/minnesota.cbslocal.com/wp-content/uploads/sites/15909630/2021/02/joe-jill-biden-1.jpg?resize=55%2C55&#038;ssl=1" alt="Stimulus Check Latest: Will Your Next Relief Payment Be $1,400?" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://minnesota.cbslocal.com/2021/02/26/stimulus-check-update-how-much-1400-covid-relief-payment/" title="Stimulus Check Latest: Will Your Next Relief Payment Be $1,400?" class="bump-view" data-bump-view="tp">Stimulus Check Latest: Will Your Next Relief Payment Be $1,400?</a>
							</div>
													</li>
										<li>
						<a href="https://minnesota.cbslocal.com/2021/02/28/police-man-dies-after-attack-in-north-minneapolis/" title="Police: Man Dies After Attack In North Minneapolis" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i2.wp.com/minnesota.cbslocal.com/wp-content/uploads/sites/15909630/2021/02/Minneapolis-Homicide-Golden-Valley-Road.jpg?resize=55%2C55&#038;ssl=1" alt="Police: Man Dies After Attack In North Minneapolis" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://minnesota.cbslocal.com/2021/02/28/police-man-dies-after-attack-in-north-minneapolis/" title="Police: Man Dies After Attack In North Minneapolis" class="bump-view" data-bump-view="tp">Police: Man Dies After Attack In North Minneapolis</a>
							</div>
													</li>
										<li>
						<a href="https://minnesota.cbslocal.com/2021/03/01/minnesota-dad-makes-thousands-a-month-reselling-thrift-store-finds/" title="Minnesota Dad Makes Thousands A Month Reselling Thrift Store Finds" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i1.wp.com/minnesota.cbslocal.com/wp-content/uploads/sites/15909630/2021/03/thrift-resller.jpg?resize=55%2C55&#038;ssl=1" alt="Minnesota Dad Makes Thousands A Month Reselling Thrift Store Finds" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://minnesota.cbslocal.com/2021/03/01/minnesota-dad-makes-thousands-a-month-reselling-thrift-store-finds/" title="Minnesota Dad Makes Thousands A Month Reselling Thrift Store Finds" class="bump-view" data-bump-view="tp">Minnesota Dad Makes Thousands A Month Reselling Thrift Store Finds</a>
							</div>
													</li>
					</ul>
</div><div id="reptile_31_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper big-right-ad sidebar-adhesive-ad"><span id="ad_31"><div id="reptile_31" class="ad-block" data-ad_size="[[300,250]]" data-ad_location="adhesion"><script>cbs_load_ad_by_tile("31");</script></div></span></div></aside></section>		<section class="page-ad-container page-pencil-ad-container-bottom">
			<div id="reptile_4_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper"><span id="ad_4"><div id="reptile_4" class="ad-block" data-ad_size="[[728,90]]" data-ad_location="bottom"><script>cbs_load_ad_by_tile("4");</script></div></span></div>		</section>
		

</div>


<footer id="page-footer" class="page-footer-type-menus-vertical">
			<section class="top"><div class="wrapper">
			<a href="https://minnesota.cbslocal.com" class="logo"><img src="https://minnesota.cbslocal.com/wp-content/uploads/sites/15909630/2017/10/minnesota-eye.png" alt="WCCO | CBS Minnesota" /></a>							<div id="component-social" class="footer-component social-follow-items type-blue size-24x24">
					<div class="social-align-wrapper">
						<span class="disclosure">Follow Us</span>
						<a href="http://facebook.com/CBSMinnesota" class="facebook" target="_blank">Facebook</a><a href="http://twitter.com/wcco" class="twitter" target="_blank">Twitter</a><a href="http://youtube.com/wcco" class="youtube" target="_blank">YouTube</a><a href="http://instagram.com/wcco" class="instagram" target="_blank">Instagram</a><a href="https://www.reddit.com/user/cbsminnesota" class="reddit" target="_blank">Reddit</a><a href="https://www.linkedin.com/company/wcco-tv/" class="linkedin" target="_blank">LinkedIn</a>					</div>
				</div>
					</div></section>
	
			<section class="middle"><div class="wrapper">
			
<section class="items-grid block-menu layout-compact aspect-ratio-16-9" id="block-0" >
		<header class="column-header">
				<h4 class="title">News</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://minnesota.cbslocal.com/category/news/local/" title="Minnesota News" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Minnesota News</strong></div></a><a href="https://minnesota.cbslocal.com/tag/minneapolis/" title="Minneapolis News" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Minneapolis News</strong></div></a><a href="https://minnesota.cbslocal.com/tag/st-paul/" title="St. Paul News" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">St. Paul News</strong></div></a><a href="https://minnesota.cbslocal.com/category/news/business/" title="Business" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">Business</strong></div></a><a href="https://minnesota.cbslocal.com/category/news/consumer/" title="Consumer" class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">Consumer</strong></div></a><a href="https://minnesota.cbslocal.com/category/news/crime/" title="Crime" class="cbs-thumbnail-link item-5" ><div class="title-wrapper"><strong class="title">Crime</strong></div></a><a href="https://minnesota.cbslocal.com/category/politics/" title="Politics" class="cbs-thumbnail-link item-6" ><div class="title-wrapper"><strong class="title">Politics</strong></div></a><a href="https://minnesota.cbslocal.com/category/news/entertainment/" title="Entertainment" class="cbs-thumbnail-link item-7" ><div class="title-wrapper"><strong class="title">Entertainment</strong></div></a><a href="/category/health/" title="HealthWatch" class="cbs-thumbnail-link item-8" ><div class="title-wrapper"><strong class="title">HealthWatch</strong></div></a><a href="https://minnesota.cbslocal.com/category/news/water-cooler/" title="Water Cooler" class="cbs-thumbnail-link item-9" ><div class="title-wrapper"><strong class="title">Water Cooler</strong></div></a>		</div>
	</section>

<section class="items-grid block-menu layout-compact aspect-ratio-16-9" id="block-1" >
		<header class="column-header">
				<h4 class="title">Weather</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://minnesota.cbslocal.com/category/weather/" title="Minnesota Weather" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Minnesota Weather</strong></div></a><a href="https://minnesota.cbslocal.com/twin-cities-area-radar/" title="Live Radar" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Live Radar</strong></div></a><a href="https://minnesota.cbslocal.com/school-closings/" title="School Closings &amp; Delays" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">School Closings &amp; Delays</strong></div></a><a href="https://minnesota.cbslocal.com/2010/11/05/put-chris-shaffer-on-the-spot/" title="On The Spot" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">On The Spot</strong></div></a><a href="https://minnesota.cbslocal.com/join-the-weather-watcher-network/" title="Weather Watcher Network" class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">Weather Watcher Network</strong></div></a><a href="http://apps.cbslocal.com/weather/minnesota/" title="Weather App" class="cbs-thumbnail-link item-5" ><div class="title-wrapper"><strong class="title">Weather App</strong></div></a>		</div>
	</section>

<section class="items-grid block-menu layout-compact aspect-ratio-16-9" id="block-2" >
		<header class="column-header">
				<h4 class="title">Sports</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://minnesota.cbslocal.com/category/sports/vikings/" title="Vikings" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Vikings</strong></div></a><a href="https://minnesota.cbslocal.com/category/sports/twins/" title="Twins" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Twins</strong></div></a><a href="https://minnesota.cbslocal.com/category/sports/wild/" title="Wild" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">Wild</strong></div></a><a href="https://minnesota.cbslocal.com/category/sports/timberwolves/" title="Timberwolves" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">Timberwolves</strong></div></a><a href="https://minnesota.cbslocal.com/category/sports/lynx/" title="Lynx" class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">Lynx</strong></div></a><a href="https://minnesota.cbslocal.com/category/sports/united/" title="United FC" class="cbs-thumbnail-link item-5" ><div class="title-wrapper"><strong class="title">United FC</strong></div></a><a href="https://minnesota.cbslocal.com/category/sports/gophers/" title="Gophers" class="cbs-thumbnail-link item-6" ><div class="title-wrapper"><strong class="title">Gophers</strong></div></a><a href="https://minnesota.cbslocal.com/category/sports/high-school-sports-rally/" title="High School Sports Rally" class="cbs-thumbnail-link item-7" ><div class="title-wrapper"><strong class="title">High School Sports Rally</strong></div></a>		</div>
	</section>

<section class="items-grid block-menu layout-compact aspect-ratio-16-9" id="block-3" >
		<header class="column-header">
				<h4 class="title">Watch + Listen</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://minnesota.cbslocal.com/video/" title="Video Library" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Video Library</strong></div></a><a href="https://minnesota.cbslocal.com/category/watch-listen/seen-on-wcco-tv/" title="Seen On WCCO-TV" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Seen On WCCO-TV</strong></div></a><a href="https://minnesota.cbslocal.com/category/only-cbs/" title="Only CBS" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">Only CBS</strong></div></a><a href="https://minnesota.cbslocal.com/category/best-of/" title="Best Of" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">Best Of</strong></div></a><a href="https://minnesota.cbslocal.com/category/contests-promotions/" title="Contests" class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">Contests</strong></div></a>		</div>
	</section>

<section class="items-grid block-menu layout-compact aspect-ratio-16-9" id="block-4" >
		<header class="column-header">
				<h4 class="title">Corporate</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://minnesota.cbslocal.com/learn-about-us/" title="About Us" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">About Us</strong></div></a><a href="https://minnesota.cbslocal.com/station/wcco-tv/" title="WCCO TV" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">WCCO TV</strong></div></a><a href="https://minnesota.cbslocal.com/about-us/advertising-basics/" title="Advertise" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">Advertise</strong></div></a><a href="https://minnesota.cbslocal.com/2010/10/01/wcco-tv-frequently-asked-questions-faqs/" title="FAQ" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">FAQ</strong></div></a><a href="http://audienceservices.cbs.com/feedback/feedback.htm" title="Broadcast Feedback" class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">Broadcast Feedback</strong></div></a>		</div>
	</section>
		</div></section>
	
			<section class="bottom"><div class="wrapper">
			<a href="https://minnesota.cbslocal.com" class="logo"><img src="https://minnesota.cbslocal.com/wp-content/themes/cbs-local/plugins/modules/theme-manager/images/cbs-local-logo-white.png" alt="WCCO | CBS Minnesota" /></a>
			<div class="copyright-wrapper">
				<span class="copyright">&copy;2021 CBS Broadcasting Inc. All Rights Reserved.</span>
									<span class="powered-by-wordpress">Powered by <a href="https://wpvip.com/?utm_source=vip_powered_wpcom&#038;utm_medium=web&#038;utm_campaign=VIP%20Footer%20Credit&#038;utm_term=minnesota.cbslocal.com" rel="generator nofollow" class="powered-by-wpcom">WordPress.com VIP</a></span>
							</div>

			<div class="right-wrapper">
									<div class="terms-of-use">By viewing our video content, you are accepting the terms of our <a href="https://privacy.cbs/videoservices" target="_blank" title="Video Services Policy">Video Services Policy</a></div>
								<ul id="menu-final-footer-menu" class="nav-final-footer"><li id="menu-item-249305" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-249305"><a href="https://privacy.cbs/">Privacy Policy</a></li>
<li id="menu-item-249307" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-249307"><a href="http://policies.cbslocal.com/terms-of-use/">Terms of Use</a></li>
<li id="menu-item-925772" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-925772"><a href="https://ca.privacy.cbs">California Privacy/Info We Collect</a></li>
<li id="menu-item-925773" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-925773"><a href="https://ca.privacy.cbs/donotsell">Do Not Sell My Personal Information</a></li>
<li id="menu-item-578874" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-578874"><a href="http://policies.cbslocal.com/mobile-app-agreement/">Mobile User Agreement</a></li>
<li id="menu-item-326271" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-326271"><a href="https://privacy.cbs/personalizedads">Ad Choices</a></li>
<li id="menu-item-878697" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-878697"><a href="http://publicfiles.fcc.gov/tv-profile/wcco-tv">Public File for WCCO-TV</a></li>
<li id="menu-item-879716" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-879716"><a href="http://publicfiles.fcc.gov/tv-profile/kccw-tv">Public File for KCCW-TV</a></li>
<li id="menu-item-879717" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-879717"><a href="https://policies.cbslocal.com/fcc/contactusfcc.html">Public Inspection File Help</a></li>
<li id="menu-item-983160" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-983160"><a href="https://minnesota.cbslocal.com/fcc-applications/">FCC Applications</a></li>
<li id="menu-item-880619" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-880619"><a href="https://minnesota.cbslocal.com/wp-content/uploads/sites/15909630/2020/11/WCCOEEO2020.pdf">EEO Report</a></li>
</ul>			</div>

						</div></section>
</footer>

<!--PARTNER SCRIPTS START-->
<div id="reptile_32_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper pixel-ad"><span id="ad_32"><div id="reptile_32" class="ad-block" data-ad_size="[[1,8]]" data-ad_location=""><script>cbs_load_ad_by_tile("32");</script></div></span></div><div id="reptile_33_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper pixel-ad"><span id="ad_33"><div id="reptile_33" class="ad-block" data-ad_size="[[1,6]]" data-ad_location=""><script>cbs_load_ad_by_tile("33");</script></div></span></div><div id="reptile_34_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper pixel-ad"><span id="ad_34"><div id="reptile_34" class="ad-block" data-ad_size="[[1,7]]" data-ad_location=""><script>cbs_load_ad_by_tile("34");</script></div></span></div>
<!--PARTNER SCRIPTS END-->


</div>

<!-- Instagram Feed JS -->
<script type="text/javascript">
var sbiajaxurl = "https://minnesota.cbslocal.com/wp-admin/admin-ajax.php";
</script>
<link rel='stylesheet' id='screen-css-0' href='https://minnesota.cbslocal.com/_static/??-eJylj1EKgCAQRC+ULVKEfURnMV1KWDXaDen2SXSC+hvmDQ8Gyq5cToJJQDaMyOAWVpSdJQjJ0elrhXFBXwm/URW0dX2oEvyK0lbQwDcTU/B4/DFkkZ3s9U9CgZ8bc5z0oHs9dsZ0N8Y6aTo=' type='text/css' media='screen' />
<link rel='stylesheet' id='all-css-0' href='https://minnesota.cbslocal.com/_static/??-eJx9jEEOwjAMBD9Ea+VQKAfEW4pjtUaOE2JHiN8TTu2J2+7OauBdBszqpA6+USIDfNggGRcBVpQW+/R8NaofEF43N+FI9ZjHxDqi2Qn+yYq0ldUg5dikk7JUV6r9Ynv5ae7pFqbrebrMIcxfP6Y7ow==' type='text/css' media='all' />
<script id='jetpack-facebook-embed-js-extra'>
var jpfbembed = {"appid":"249643311490","locale":"en_US"};
</script>
<script type='text/javascript' src='https://minnesota.cbslocal.com/_static/??-eJyVjUEOwjAMBD+E41YqqD0gnoKaxCCnsRMRR/0+5dYrx5VmZnGvEIoaqaF0qLm/WRsmsrqGDRY34ZM1oO+cI77WQL6UDUg8RSesLrUL/tWwnc3oA8ZCmZXOlYPKPdLhtt88vzzkPt7GaRiW+TqnL/btQSg='></script>
<script src='https://widgets.media.weather.com/wxwidget.loader.js?cid=934888385&#038;ver=1.1' id='cbs-weather-widget-js'></script>
<script src='https://w3.cdn.anvato.net/player/prod/v3/scripts/anvload.js?ver=5.6.2' id='cbs-cbs-anvato-js'></script>
<script type='text/javascript' src='https://minnesota.cbslocal.com/_static/??-eJytzEEOQDAQQNELqdEQYiHOQjuhzbRFpxG3ZyFiaWH38xcP9kWo4Bk9A8/oMIIao6CgBgLjFSV9Lbsm3A4gM80cyWjc3p0743MbM/hkoRtRX+Rd4g8jMC80HA/Tu07WRVO0lSylPQGfjFQ9'></script>
<script src='https://stats.wp.com/e-202109.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:9.4.1',blog:'162246174',post:'1002373',tz:'-6',srv:'minnesota.cbslocal.com'} ]);
	_stq.push([ 'clickTrackerInit', '162246174', '1002373' ]);
</script>



<script type="text/javascript">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</script>

	
	
	
	
</body>
</html>